Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Här kan man ställa alla typer av segelbåtsrelaterade frågor som inte passar i någon annan kategori
Skriv svar
Användarvisningsbild
thomask
Diamantmedlem
Inlägg: 395
Blev medlem: tis 05 sep 2006, 18:08

Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av thomask » sön 18 maj 2014, 13:26

Tp22 wiring.png
Garmin wiring.jpg
Har försökt ett tag att få till det, så jag styra ap efter Way Point i plottern (Garmin 720)
Den funkar bra att styra efter kompassriktning, och höger/vänster. Men jag lyckas inte få ut någon signal via nmea.
Har ändrat plottern till nmea standard, vet inte riktigt mer vad som ska ändras.
När jag trycker på NAVknappen i ap så kommer det bara två pip. ingen lampa som tänds.
Om någon här ha liknande apparater, och vet hur man får till det...... :)
Plotterns blå kabel har jag till ap röd.
Plotterns bruna har jag till ap blå.
Hoppas jag tänkt rätt där.

LasseT
Guldmedlem
Inlägg: 85
Blev medlem: sön 04 nov 2007, 21:34
Ort: Lomma

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av LasseT » sön 18 maj 2014, 17:13

Hej,

Under förutsättning att det är port1 du har satt upp på Garmin 720 som sändare hade jag kopplat:

720 - Autopilot
Blå - Röd
Svart - Blå

/Lasse T
Contrast 36

Användarvisningsbild
thomask
Diamantmedlem
Inlägg: 395
Blev medlem: tis 05 sep 2006, 18:08

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av thomask » mån 19 maj 2014, 06:22

Oj! :o
Hur menar du nu?
Svart (Batteriminus) från plottern både till batteriet OCH autopilotens nmea-utgång? (blå) i detta fallet.
Tänkte att autopiloten har ju redan batteri-jord.
Sim22.JPG

robin_bockman
Trogen medlem
Inlägg: 14
Blev medlem: tor 21 apr 2005, 10:47

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av robin_bockman » mån 19 maj 2014, 11:48

Garmin kör inte med separat nmea minuspol utan kör den på sin vanliga batteriminus, så allt du kopplar till en garmin går alltså på den, ingång som utgång

peterh
Diamantmedlem
Inlägg: 1208
Blev medlem: tor 12 feb 2009, 13:31
Ort: göteborg

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av peterh » mån 19 maj 2014, 18:32

robin_bockman skrev:Garmin kör inte med separat nmea minuspol utan kör den på sin vanliga batteriminus, så allt du kopplar till en garmin går alltså på den, ingång som utgång
För att tala klartext : Garmin fuskar, de följer inte nmea 0183 som föreskriver rc422 ( dvs signalen i två ledare som går i "motfas").
Se http://en.wikipedia.org/wiki/NMEA_0183

Jag löste ett liknande problem med tacktics nmea interface, som också fuskar, genom att köpa en rc232 till rs485 converter på
electrokit.se. I tackticks fall så lämnar den 0-4V, något som kan driva på "TTL" nivå, alltså direkt kunde driva den
MAX-krets som användes. ( jag fick alltså utelämna en del av kretsen)

http://www.electrokit.com/rs232-rs485-interface-r.46114

Nu har jag för mig att garmin lämnar -5 till +5V , så den driver antagligen en rs232 korrekt. Då skall man använda hela electrokit's krets.
Numera ex-medlem. Tack för det som varit.

Användarvisningsbild
thomask
Diamantmedlem
Inlägg: 395
Blev medlem: tis 05 sep 2006, 18:08

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av thomask » tis 20 maj 2014, 07:27

Det blir bara värre o värre!
Åker ut i eftermiddag och provar att lägga autopilotens blåa kabel på jordplinten,
Kan ju inte mer än gå fel :?

robin_bockman
Trogen medlem
Inlägg: 14
Blev medlem: tor 21 apr 2005, 10:47

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av robin_bockman » tis 20 maj 2014, 10:12

Så mycket tydligare blev det inte, du ska, som du skriver koppla plottern både till batteriet OCH autopilotens nmea-utgång, du vill ha samma längd på nmeakabeln i plus och minus, för att förvirra så kallar simrad det tydligen för nmea common, splitta alltså upp garrmins svarta i 2

Användarvisningsbild
thomask
Diamantmedlem
Inlägg: 395
Blev medlem: tis 05 sep 2006, 18:08

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av thomask » tis 20 maj 2014, 18:00

NÄ, AP-fan ger mig bara två pip i protest.
Tog ap nmeaut (blå) och la på jordplinten som är delad med plotterns svarta jord.
Det enda jag kommer på nu att jag hade inte plotterns bruna kabel ansluten. men den ska väl ändå bara ta emot en ev nmea signal??

Har provat alla tänkbara inställningar på Garminen, (decimaler,namn/nummer mm,mm med samma resultat.
Den visar bara 0-värde i den inbyggda diagnostiken.

Lossnar det inte snart, så får den duga till att hålla kursen vid kaffekokandet.

Användarvisningsbild
thomask
Diamantmedlem
Inlägg: 395
Blev medlem: tis 05 sep 2006, 18:08

Re: Få Garmin att skicka signal till Simrad tp22 (nmea0183)

Inlägg av thomask » ons 21 maj 2014, 19:46

TACK för alla svar, Nu funkar det!!!!!! :P
Garmins batteriminus ska även gå till ap-ut som ni sa. (delad kabel)
Var inne hos två återförsäljare idag, och frågade vad fasen det kunde vara, den sista sa att ibland blir kabelstammarna (simrad??) felkopplade i kontaktdonen, Och visst funkade det direkt när jag satte kablarna tvärtom! (Nmea ut /in)

Enda frågetecknet nu, är att det blir så himla stora svängar när det är inlagt EX, 90 graders girar i rutten. Är det ap som ställas att hantera det kvickare??

/Thomas

Skriv svar